Odoo10登录后无菜单项显示了



  • 我是在windows上装的odoo10。
    今天重新启动之后就发现了这样的问题,登录页面之后啥内容都看不到。显示如下图所示:0_1485307821355_Snip20170125_1.png
    基本上我都是通过界面做的一些操作。唯一就是我也同时用其它数据库客户端访问数据库,并且在数据库的每个表的注释中加了些中文解释,会是因为这个原因么?


  • 管理员

    如果你知道如何通过命令行启动服务器,请使用下面的命令行更新数据库试试

    odor-bin.exe -dYourDBName -uall
    

    替换YourDBName 为你自己的账套(数据库)名。



  • 我的也是这样,貌似没有人可以解决。可能就是odoo 10的 bug



  • 清楚cookie重新登录,或者因为重启后数据库没加载上,F12调试js。



  • 那最后你的这个问题解决了没?怎么解决的。我也出现了这个问题,一模一样。



  • 换个浏览器,我用360浏览器也出现这个情况,换了ie10就正常了



  • @victorlin2100 我的也是这个问题,换了好几个浏览器都不行。



  • @deardavid

    我说你们都不看log吗



  • win10系统,查看启动日志,问题应该是:
    2017-04-02 14:10:00,105 18484 INFO d02 odoo.models.unlink: User #1 deleted ir.attachment records with IDs: [248, 247]
    2017-04-02 14:10:00,661 18484 INFO d02 odoo.models.unlink: User #1 deleted ir.attachment records with IDs: [249]
    2017-04-02 14:10:01,598 18484 INFO d02 odoo.models.unlink: User #1 deleted ir.attachment records with IDs: [250]
    2017-04-02 14:10:02,648 18484 INFO d02 odoo.models.unlink: User #1 deleted ir.attachment records with IDs: [252]
    2017-04-02 14:10:02,835 18484 INFO d02 odoo.models.unlink: User #1 deleted ir.attachment records with IDs: [253]
    2017-04-02 14:10:03,118 18484 INFO d02 odoo.models.unlink: User #1 deleted ir.attachment records with IDs: [254]
    初步判断是odoo加载lessc文件的问题,换浏览器(IE,CHROME,360),新建数据库,重装node.js,less,下载最新源码重装odoo,都没法解决问题,实在没折,只好在ubantu下跑了,一切OK
    因为开发环境是windows,还是盼高手能在windows下解决



  • 我用IE浏览器也是这样 , 换火狐就好了,IE浏览器JS报错


登录后回复
 

与 Odoo 中文社区 的连接断开,我们正在尝试重连,请耐心等待