Odoo中文社区可以通过以下三个域名访问:shine-it.net , odoocn.org,odoo.net.cn

原论坛用户的基本信息和发帖这里都予以保留,请注意:原论坛用户无需重新注册新用户,但是您的密码需要重置

开发人员可以登录gitter讨论组: http://gitter.im/odoo-china/Talk, 需要github账号

如果您登录系统碰到问题,请在微信公众号留言:

Openerp7.0运行服务器端报错的问题,请大侠帮忙,谢谢!



  • C:\Python27\python.exe E:/openerp/openerp-7.0-latest/openerp-7.0-20130717-231254/openerp-server<br />2016-04-16 15:23:59,558 5224 INFO ? openerp: OpenERP version 7.0-20130717-231254<br />2016-04-16 15:23:59,559 5224 INFO ? openerp: addons paths: E:\openerp\openerp-7.0-latest\openerp-7.0-20130717-231254\openerp\addons<br />2016-04-16 15:23:59,559 5224 INFO ? openerp: database hostname: localhost<br />2016-04-16 15:23:59,559 5224 INFO ? openerp: database port: 5432<br />2016-04-16 15:23:59,561 5224 INFO ? openerp: database user: openerp<br />2016-04-16 15:24:00,275 5224 CRITICAL ? openerp.modules.module: Couldn't load module web<br />2016-04-16 15:24:00,276 5224 CRITICAL ? openerp.modules.module: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?<br />2016-04-16 15:24:00,276 5224 ERROR ? openerp.service: Failed to load server-wide module web.<br />The web module is provided by the addons found in the openerp-web project.<br />Maybe you forgot to add those addons in your addons_path configuration.<br />Traceback (most recent call last):<br />  File "E:\openerp\openerp-7.0-latest\openerp-7.0-20130717-231254\openerp\service_init_.py", line 60, in load_server_wide_modules<br />    openerp.modules.module.load_openerp_module(m)<br />  File "E:\openerp\openerp-7.0-latest\openerp-7.0-20130717-231254\openerp\modules\module.py", line 405, in load_openerp_module<br />    import('openerp.addons.' + module_name)<br />  File "E:\openerp\openerp-7.0-latest\openerp-7.0-20130717-231254\openerp\modules\module.py", line 133, in load_module<br />    mod = imp.load_module('openerp.addons.' + module_part, f, path, descr)<br />  File "E:\openerp\openerp-7.0-latest\openerp-7.0-20130717-231254\openerp\addons\web_init_.py", line 3, in <module><br />    import cli<br />  File "E:\openerp\openerp-7.0-latest\openerp-7.0-20130717-231254\openerp\addons\web\cli_init_.py", line 1, in <module><br />    import test_js<br />  File "E:\openerp\openerp-7.0-latest\openerp-7.0-20130717-231254\openerp\addons\web\cli\test_js.py", line 8, in <module><br />    import openerp.addons.web.tests<br />  File "E:\openerp\openerp-7.0-latest\openerp-7.0-20130717-231254\openerp\addons\web\tests_init_.py", line 2, in <module><br />    from . import test_dataset, test_menu, test_serving_base, test_js<br />  File "E:\openerp\openerp-7.0-latest\openerp-7.0-20130717-231254\openerp\addons\web\tests\test_dataset.py", line 2, in <module><br />    import mock<br />  File "C:\Python27\lib\site-packages\mock_init_.py", line 2, in <module><br />    import mock.mock as _mock<br />  File "C:\Python27\lib\site-packages\mock\mock.py", line 71, in <module><br />    _v = VersionInfo('mock').semantic_version()<br />  File "C:\Python27\lib\site-packages\pbr\version.py", line 460, in semantic_version<br />    self._semantic = self._get_version_from_pkg_resources()<br />  File "C:\Python27\lib\site-packages\pbr\version.py", line 447, in _get_version_from_pkg_resources<br />    result_string = packaging.get_version(self.package)<br />  File "C:\Python27\lib\site-packages\pbr\packaging.py", line 710, in get_version<br />    raise Exception("Versioning for this project requires either an sdist"<br />Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?<br />2016-04-16 15:24:00,316 5224 INFO ? openerp: OpenERP server is running, waiting for connections...<br />2016-04-16 15:24:00,335 5224 INFO ? openerp.service.wsgi_server: HTTP service (werkzeug) running on 0.0.0.0:8069



  • C:\Python27\python.exe E:/openerp/openerp-7.0-latest/openerp-7.0-20130717-231254/openerp-server<br />2016-04-16 15:23:59,558 5224 INFO ? openerp: OpenERP version 7.0-20130717-231254<br />2016-04-16 15:23:59,559 5224 INFO ? openerp: addons paths: E:\openerp\openerp-7.0-latest\openerp-7.0-20130717-231254\openerp\addons<br />2016-04-16 15:23:59,559 5224 INFO ? openerp: database hostname: localhost<br />2016-04-16 15:23:59,559 5224 INFO ? openerp: database port: 5432<br />2016-04-16 15:23:59,561 5224 INFO ? openerp: database user: openerp<br />2016-04-16 15:24:00,275 5224 CRITICAL ? openerp.modules.module: Couldn't load module web<br />2016-04-16 15:24:00,276 5224 CRITICAL ? openerp.modules.module: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?<br />2016-04-16 15:24:00,276 5224 ERROR ? openerp.service: Failed to load server-wide module web.<br />The web module is provided by the addons found in the openerp-web project.<br />Maybe you forgot to add those addons in your addons_path configuration.<br />Traceback (most recent call last):<br />  File "E:\openerp\openerp-7.0-latest\openerp-7.0-20130717-231254\openerp\service_init_.py", line 60, in load_server_wide_modules<br />    openerp.modules.module.load_openerp_module(m)<br />  File "E:\openerp\openerp-7.0-latest\openerp-7.0-20130717-231254\openerp\modules\module.py", line 405, in load_openerp_module<br />    import('openerp.addons.' + module_name)<br />  File "E:\openerp\openerp-7.0-latest\openerp-7.0-20130717-231254\openerp\modules\module.py", line 133, in load_module<br />    mod = imp.load_module('openerp.addons.' + module_part, f, path, descr)<br />  File "E:\openerp\openerp-7.0-latest\openerp-7.0-20130717-231254\openerp\addons\web_init_.py", line 3, in <module><br />    import cli<br />  File "E:\openerp\openerp-7.0-latest\openerp-7.0-20130717-231254\openerp\addons\web\cli_init_.py", line 1, in <module><br />    import test_js<br />  File "E:\openerp\openerp-7.0-latest\openerp-7.0-20130717-231254\openerp\addons\web\cli\test_js.py", line 8, in <module><br />    import openerp.addons.web.tests<br />  File "E:\openerp\openerp-7.0-latest\openerp-7.0-20130717-231254\openerp\addons\web\tests_init_.py", line 2, in <module><br />    from . import test_dataset, test_menu, test_serving_base, test_js<br />  File "E:\openerp\openerp-7.0-latest\openerp-7.0-20130717-231254\openerp\addons\web\tests\test_dataset.py", line 2, in <module><br />    import mock<br />  File "C:\Python27\lib\site-packages\mock_init_.py", line 2, in <module><br />    import mock.mock as _mock<br />  File "C:\Python27\lib\site-packages\mock\mock.py", line 71, in <module><br />    _v = VersionInfo('mock').semantic_version()<br />  File "C:\Python27\lib\site-packages\pbr\version.py", line 460, in semantic_version<br />    self._semantic = self._get_version_from_pkg_resources()<br />  File "C:\Python27\lib\site-packages\pbr\version.py", line 447, in _get_version_from_pkg_resources<br />    result_string = packaging.get_version(self.package)<br />  File "C:\Python27\lib\site-packages\pbr\packaging.py", line 710, in get_version<br />    raise Exception("Versioning for this project requires either an sdist"<br />Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?<br />2016-04-16 15:24:00,316 5224 INFO ? openerp: OpenERP server is running, waiting for connections...<br />2016-04-16 15:24:00,335 5224 INFO ? openerp.service.wsgi_server: HTTP service (werkzeug) running on 0.0.0.0:8069



  • python版本是2.7.8,错误提示也没说模块有问题,我感觉是pbr的问题,我的pbr版本是1.9.1最新的



  • centos 没玩过,<br />看了下问题,比较好奇,为何 版本是:openerp-7.0-20130717-231254<br />这么老的一个版本。



  • 我的os版本是win10 x64,不是centos,版本新的也报错,比如9


登录后回复
 

与 Odoo 中文社区 的连接断开,我们正在尝试重连,请耐心等待