Odoo中文社区可以通过以下三个域名访问:shine-it.net , odoocn.org,odoo.net.cn

原论坛用户的基本信息和发帖这里都予以保留,请注意:原论坛用户无需重新注册新用户,但是您的密码需要重置

开发人员可以登录gitter讨论组: http://gitter.im/odoo-china/Talk, 需要github账号

如果您登录系统碰到问题,请在微信公众号留言:

Openerp 8.0 安装后, openerp-server-8.0 启动后自动停止



  • openerp 8.0  安装后, openerp-server-8.0 启动后自动停止<br /><br />用的是最新版本<br />http://nightly.openerp.com/8.0/nightly/exe/odoo_8.0rc1-20140914-000206.exe <br /><br />请哪位大侠支个招



  • openerp 8.0  安装后, openerp-server-8.0 启动后自动停止<br /><br />用的是最新版本<br />http://nightly.openerp.com/8.0/nightly/exe/odoo_8.0rc1-20140914-000206.exe <br /><br />请哪位大侠支个招


  • 管理员

    请贴出openerp的server log



  • openerp 中没有找到相关的 log 文件,整个系统中没有找到 openerp-server.log<br /><br />在服务器的事件查看器中,有如下信息:(在win7 和 win2003 中均是这样的错误信息)<br />--------------------------------------------------------<br />事件类型: 错误<br />事件来源: openerp-server-8.0<br />事件种类: 无<br />事件 ID: 3<br />日期: 2014-09-15<br />事件: 11:23:18<br />用户: N/A<br />计算机: MYSRVR<br />描述:<br />The instance's SvcRun() method failed <br />Traceback (most recent call last):<br />  File "win32serviceutil.pyo", line 835, in SvcRun<br />  File "win32_service.pyo", line 42, in SvcDoRun<br />SystemExit: 255 <br />%2: %3<br />---------------------------------------------<br /> <br />



  • 我也碰到这个问题



  • 试试步科制作的绿色版:http://shine-it.net/index.php/topic,5811.0.html



  • 我也遇到同样问题<br /><br />postgresql-2014-09-22_102357.log<br /><br />2014-09-22 11:41:38 HKT 日志:  无效的启动包长度<br /><br />



  • 百度也查不到<br />不知道是什么意思



  • 我也遇到了,windows服务里两个服务显示启动的,但是 localhost:8069就是打不开,500错误<br />我是第一次装openerp,



  • 我又在家里的windows7上安装了下22号码的版本 正常。<br /><br />但是在xp下就是这个问题。<br />



  • 我今天装了2014-9-24号的版本,也没有这个问题了<br />估计这是14号版本的bug



  • [quote author=Joshua link=topic=16605.msg28975#msg28975 date=1410748140]<br />请贴出openerp的server log<br />[/quote]<br /><br />服务都无法启动,去哪里看日志!



  • WIN7 64 位<br />今天装 odoo_8.0-20140924-000206.exe  <br />依然 是  odoo-server  服务启动后自动停止<br />



  • 下载最近25号的版本,也出现openerp-server-8.0 启动后自动停止。在win7和XP下遇到同样的问题。我试了各位说的各种版本,还是一样的问题。求救!



  • 我就是想问这个问题,我在window 8上安装的,原来安装的OE7还是好用的,以为有冲突,卸载OE7安装依然是这个问题。



  • 我同样的问题,试过buke的allinone绿色版8.0,官方allinone8.0-latest,官方allinone7.0-latest,都是同样的症状,家里(官方8.0-7.0)和公司机器(buke绿色allinone)都是。<br />进入安装目录,cmd下手动启动openerp-server,显示出错信息如下:<br />Traceback (most recent call last):<br />  File "openerp-server", line 2, in <module><br />  File "C:\PROGRA~1\Odoo 8.0-20141015-000206\server.\openerp_init_.py", line<br /> 78, in <module><br />    import service<br />  File "C:\PROGRA~1\Odoo 8.0-20141015-000206\server.\openerp\service_init_.p<br />y", line 27, in <module><br />    import wsgi_server<br />  File "C:\PROGRA~1\Odoo 8.0-20141015-000206\server.\openerp\service\wsgi_serve<br />r.py", line 46, in <module><br />    import websrv_lib<br />  File "C:\PROGRA~1\Odoo 8.0-20141015-000206\server.\openerp\service\websrv_lib<br />.py", line 37, in <module><br />    from SimpleHTTPServer import SimpleHTTPRequestHandler<br />  File "SimpleHTTPServer.pyc", line 27, in <module><br /><br />  File "SimpleHTTPServer.pyc", line 208, in SimpleHTTPRequestHandler<br /><br />  File "mimetypes.pyc", line 358, in init<br /><br />  File "mimetypes.pyc", line 258, in read_windows_registry<br />    --extension / -e  -- guess extension instead of type<br />  File "mimetypes.pyc", line 249, in enum_types<br /><br />UnicodeDecodeError: 'ascii' codec can't decode byte 0xb0 in position 1: ordinal<br />not in range(128)<br /><br />事件查看器中错误提示如楼主所说。非常莫名其妙<br />==========<br />更新:<br />10-16 今早到公司,用昨晚下载的openerp-allinone-setup-7.0-20140622-231040(大小72m)安装,成功启动。昨晚家里安装用的是openerp_7.0-latest(122m).都是官方的。



  • 解决:<br />参见我的发问。感谢mrshelly点拨。



  • 你好,请问这个问题怎么解决的呢?



  • 我的windows2003 32bit安装官方的odoo_8.0-latest.exe也是报这个错。<br />The instance's SvcRun() method failed <br />Traceback (most recent call last):<br />  File "win32serviceutil.pyo", line 835, in SvcRun<br />  File "win32_service.pyo", line 42, in SvcDoRun<br />SystemExit: 255 <br />%2: %3



  • 遇到同样问题,求解。


登录后回复
 

与 Odoo 中文社区 的连接断开,我们正在尝试重连,请耐心等待